Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Meaco DD8L Dehumidifier Not Working

  1. #1
    AndrewE's Avatar
    AndrewE is offline Hey look at that Peugot 406! Oh no it's a Ferrari 360 Club Member
    Join Date
    Aug 2008
    Location
    Leigh
    Name
    Andrew
    Posts
    1,900

    Default Meaco DD8L Dehumidifier Not Working

    Hi,

    I have had a Meaco DDL8 for just under a year and it seems to have just completely stopped working
    I thought it was due to cold weather putting the dehumidifier in closed mode but when I press the on / off button nothing works
    Fuse in plug is fine as it socket into which it is plugged

    Any ideas what is wrong with it or how to reactivate or fix it

    Andrew

  2. #2
    milkshaker0007's Avatar
    milkshaker0007 is offline Only 37 known common faults - The Ferrari 355 Club Member
    Join Date
    Aug 2012
    Location
    South west Birmingham
    Name
    paul
    Posts
    1,077

    Default

    My delonghi will stop if the filter is very dirty, but the power light will still be "lit" up.
    Do you have any lights "lit up" when switched on??

  3. #3
    Nosevi's Avatar
    Nosevi is offline I have no life Super Moderator
    Join Date
    Jun 2011
    Location
    Lincolnshire
    Name
    Nos
    Posts
    9,889

    Default

    They all have either a 2 or 3 year warrantee I think, although you have to ‘activate’ the warantee on Meaco’s site. Possibly worth just getting a new one as it won’t cost you anything.

    https://www.meaco.com/warranty-register

  4. #4
    AndrewE's Avatar
    AndrewE is offline Hey look at that Peugot 406! Oh no it's a Ferrari 360 Club Member
    Join Date
    Aug 2008
    Location
    Leigh
    Name
    Andrew
    Posts
    1,900

    Default

    Quote Originally Posted by milkshaker0007 View Post
    My delonghi will stop if the filter is very dirty, but the power light will still be "lit" up.
    Do you have any lights "lit up" when switched on??
    No lights whatsoever

  5. #5
    milkshaker0007's Avatar
    milkshaker0007 is offline Only 37 known common faults - The Ferrari 355 Club Member
    Join Date
    Aug 2012
    Location
    South west Birmingham
    Name
    paul
    Posts
    1,077

    Default

    Quote Originally Posted by AndrewE View Post
    No lights whatsoever
    Return to sender then

  6. #6
    MoreThanPolish is offline Only 37 known common faults - The Ferrari 355 Sponsor
    Join Date
    Sep 2010
    Location
    England
    Name
    Mark Wibberley
    Posts
    1,138

    Default

    Contact your supplier who will have it collected and returned (repaired or replaced). Std warranty if 12 months, expendable if you did so at point of purchase.

    If no lights and you've tried it in a humid place like your bathroom, and the filters are clean, then contact whoever you got it from. if it was us, we'll take care of it for you.

  7. #7
    Join Date
    Mar 2017
    Location
    Ipswich, Suffolk
    Name
    Will Finch
    Posts
    18

    Default

    Should be covered under warranty!

    If not, this may be of help: http://www.ybw.com/forums/showthread...L-Dehumidifier

  8. #8
    milkshaker0007's Avatar
    milkshaker0007 is offline Only 37 known common faults - The Ferrari 355 Club Member
    Join Date
    Aug 2012
    Location
    South west Birmingham
    Name
    paul
    Posts
    1,077

    Default

    Great find
    If it was mine and out of warranty (not sure if it is)
    you have nothing to lose and take a look, multimeter to hand and away you go, obviously if so inclined and like to tinker which I do.

  9. #9
    Mike01606's Avatar
    Mike01606 is offline Looks like a 308 to me? -The Ferrari 288 GTO Club Member
    Join Date
    Jan 2012
    Location
    Cheshire
    Name
    Mike M
    Posts
    2,860

    Default Meaco DD8L Dehumidifier Not Working

    Quote Originally Posted by WF36 View Post
    Should be covered under warranty!

    If not, this may be of help: http://www.ybw.com/forums/showthread...L-Dehumidifier
    My kind of fix that and a thermal fuse is a good possibility.....

    I never thought Id contribute to a dehumidifier thread again [emoji23]


    Sent from my iPhone using Tapatalk

  10. #10
    AndrewE's Avatar
    AndrewE is offline Hey look at that Peugot 406! Oh no it's a Ferrari 360 Club Member
    Join Date
    Aug 2008
    Location
    Leigh
    Name
    Andrew
    Posts
    1,900

    Default

    Hmm I thought it might be thermal fuse but after trying to fix a previously purchased one without success, and the fact that this one is still in warranty I'm now in contact with Meaco for it to be retreived and repaired (I hope)

Page 1 of 2 12 LastLast

Similar Threads

  1. Why you need to use a dehumidifier
    By MoreThanPolish in forum Ferrari Talk
    Replies: 103
    Last Post: 28-07-2016, 01:51 PM
  2. Why you DONT need to use a dehumidifier
    By 360trev in forum Ferrari Talk
    Replies: 61
    Last Post: 25-02-2016, 09:51 PM
  3. Dehumidifier?
    By Lee Jones Jnr in forum Lounge
    Replies: 21
    Last Post: 20-09-2010, 10:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •